@Chilling
2017-07-23T20:33:30.000000Z
字数 1443
阅读 982
KMP
Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
题意:给出一个字符串,统计从某个位置之前出现了几次重复的串。
#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e6 + 5;
char s[maxn];
int Next[maxn];
void getNext(char s[])
{
int len = strlen(s);
Next[0] = -1;
int j = 0, k = -1;
while(j < len)
{
if(k == -1 || s[j] == s[k])
Next[++j] = ++k;
else
k = Next[k];
}
}
void KMP_Count(char t[])///统计单串中从某个位置以前有多少重复的串
{
int tlen = strlen(t);
for(int i = 2; i <= tlen; ++i)
{
int tmp = i - Next[i];
if(i % tmp == 0 && i / tmp > 1)
printf("%d %d\n", i, i / tmp);
}
}
int main()
{
int n, o = 0;
while(scanf("%d", &n), n)
{
scanf("%s", s);
getNext(s);
printf("Test case #%d\n", ++o);
KMP_Count(s);
printf("\n");
}
return 0;
}