@Chilling
2016-08-11T15:29:36.000000Z
字数 1360
阅读 1267
数论
Description
To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.
(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).
Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.
Input
Line 1: A single integer, N
Lines 2..N+1: The serial numbers to be tested, one per line
Output
Sample Input
4
36
38
40
42
Sample Output
38
题意:输入n,再输入n个数,找出n个数当中拥有最大素因子的数,如果同时拥有最大的素因子,输出先输入的那个数。
分析:利用埃式筛法,预处理1-20000内的素数,然后判断…xjb写一下就可以(´・ω・`)
#include<stdio.h>
#include<math.h>
#include<string.h>
#define maxn 20005
bool isprime[maxn];
void primeform()
{
memset(isprime,true,sizeof(isprime));
int m=(int)sqrt(maxn+0.5)+1;
for(int i=2;i<=maxn/2;i++)
{
if(isprime[i])
for(int j=i*2;j<=maxn;j+=i)
isprime[j]=false;
}
}
int main()
{
int n,x,i,m,y;
primeform();
while(scanf("%d",&n)!=EOF)
{
m=-1;
while(n--)
{
scanf("%d",&x);
for(i=1;i<=x;i++)
{
if(x%i==0&&isprime[x/i])
{
if(x/i>m)
{
m=x/i;
y=x;
}
break;
}
}
}
printf("%d\n",y);
}
return 0;
}