@Chilling
2016-08-20T14:10:29.000000Z
字数 2187
阅读 989
DP
Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000.
The last line of the input file will be 0 0 0 0 0 0; do not process this line.
Output
For each colletcion, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.".
Output a blank line after each test case.
Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0
Sample Output
Collection #1:
Can't be divided.
Collection #2:
Can be divided.
题意:价值1-6的六个物品,输入他们的个数,判断是否能够平分为价值相当的两份。
分析:多重背包+二进制优化
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
int a[7],i,s,k,flag,mid,j,dp[100005],t=0,v[100005];
while(1)
{
memset(dp,0,sizeof(dp));
memset(v,0,sizeof(v));
flag=0;
s=0;
for(i=1;i<=6;i++)
{
scanf("%d",&a[i]);
s+=a[i]*i;
if(a[i]!=0)
flag=1;
}
if(flag==0)
break;
else
{
if(s%2==1)
{
printf("Collection #%d:\n",++t);
printf("Can't be divided.\n");
}
else
{
int c=1;
for(i=1;i<=6;i++) //二进制优化,把数量拆分成2的几次方
{
for(j=1;j<=a[i];j*=2)
{
v[c++]=j*i;
a[i]-=j;
}
if(a[i]>0) //余下的单独算
v[c++]=a[i]*i;
}
/* for(i=1;i<c;i++)
printf("%d\n",v[i]);*/
//输出之后发现其实就是变成01背包了……
mid=s/2;
for(i=0;i<c;i++)
for(j=mid;j>=v[i];j--)
dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
if(dp[mid]==mid)
{
printf("Collection #%d:\n",++t);
printf("Can be divided.\n");
}
else
{
printf("Collection #%d:\n",++t);
printf("Can't be divided.\n");
}
}
}
printf("\n");
}
return 0;
}