@Chilling
2017-03-04T10:55:05.000000Z
字数 1922
阅读 897
区间DP
Description
We give the following inductive definition of a “regular brackets” sequence:
the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:
(), [], (()), ()[], ()[()]
while the following character sequences are not:
(, ], )(, ([)], ([(]
Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.
Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].
Input
The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.
Output
For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.
Sample Input
((()))
()()()
([]])
)[)(
([][][)
end
Sample Output
6
6
4
0
6
题意:括号匹配问题,问有多少个括号是合法匹配的,见样例。
分析:定义dp[i][j]为从i到j最多的合法匹配数量。那么我们可以由一个小范围内i到j的最大合法匹配数推及到整个长度的最大匹配数,因此这是一个区间dp。
若现在求(st,en)区间内匹配数,已知(st+1,en-1)区间,并且s[st]与s[en]匹配,那么有:;
枚举区间内断点k,那么有:
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
char s[111];
int dp[111][111];
int main()
{
int l,st,k;
while(scanf("%s",s)!=EOF)
{
if(s[0]=='e')
break;
memset(dp,0,sizeof(dp));
int len=strlen(s);
for(l=1;l<=len;l++) //长度
{
for(st=0;st<=len-l;st++)//起点
{
int en=st+l-1;
if((s[st]=='('&&s[en]==')')||(s[st]=='['&&s[en]==']'))
dp[st][en]=dp[st+1][en-1]+2;
for(k=st;k<en;k++)
dp[st][en]=max(dp[st][en],dp[st][k]+dp[k+1][en]);
}
}
printf("%d\n",dp[0][len-1]);
}
return 0;
}