@Chilling
2016-08-11T15:29:28.000000Z
字数 871
阅读 887
数论
Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
Output
For each test case, you should print the sum module 1000000007 in a line.
Sample Input
3
4
0
Sample Output
0
2
题意:求小于n并且与n不互质的数的和。
分析:欧拉函数求出phi(n),小于n并且与n互质的数的和为:
n*phi(n)/2
。小于n的所有数的和减去与n互质的数的和。
#include<stdio.h>
#include<math.h>
#define LL long long
#define MOD 1000000007
LL phi(LL n)
{
//LL m=(LL)sqrt(n+0.5) //开方很慢,265ms
LL ans=n;
for(LL i=2;i*i<=n;i++) //写成i*i<=n而不是i<=m,15ms
if(n%i==0)
{
ans=ans/i*(i-1);
while(n%i==0)
n/=i;
}
if(n>1)
ans=ans/n*(n-1);
return ans;
}
int main()
{
LL n;
while(scanf("%lld",&n),n)
{
// n*phi(n)/2 小于n且与n互质的数的和
printf("%lld\n",(n*(n-1)/2-n*phi(n)/2)%MOD);
}
return 0;
}