@Chilling
2016-08-19T18:02:32.000000Z
字数 1523
阅读 1016
杂
Description
In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,
Ultra-QuickSort produces the output
0 1 4 5 9 .
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5
9
1
0
5
4
3
1
2
3
0
Sample Output
6
0
#include<stdio.h>
int a[500005],b[500005];
long long ans;
void merge(int m[],int temp[],int start,int mid,int end)
{
int i=start,j=mid+1,cnt=start;
while(i<=mid&&j<=end)
{
if(m[i]<=m[j])
temp[cnt++]=m[i++];
else
{
temp[cnt++]=m[j++];
ans=ans+mid-i+1;
}
}
while(i<=mid)
temp[cnt++]=m[i++];
while(j<=end)
temp[cnt++]=m[j++];
for(i=start;i<=end;i++)
m[i]=temp[i];
}
void mergesort(int m[],int temp[],int start,int end)
{
if(start==end)return;
int mid=(start+end)/2;
mergesort(m,temp,start,mid);
mergesort(m,temp,mid+1,end);
merge(m,temp,start,mid,end);
}
int main()
{
int n,i;
while(scanf("%d",&n),n)
{
ans=0;
for(i=0;i<n;i++)
scanf("%d",&a[i]);
mergesort(a,b,0,n-1);
printf("%lld\n",ans);
}
return 0;
}