@Chilling
2016-08-11T15:29:45.000000Z
字数 1370
阅读 846
数论
Description
Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?
No? Oh, you must do this when you want to become a "Big Cattle".
Now you will find that this problem is so familiar:
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem:
Given an integer N, please count the number of the integers M (01.
This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.
Good Luck!
Input
Input contains multiple test cases. Each test case contains an integers N(1< N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.
Output
For each integers N you should output the number of integers M in one line, and with one line of output for each line in input.
Sample Input
2
4
0
Sample Output
0
1
欧拉函数:在数论,对正整数n,欧拉函数是小于等于n的数中与n互质的数的数目(包含1在内)。例如phi(8)=4,因为1,3,5,7均和8互质。
题意: 求解小于n的正整数中与n不互质的数的个数。
分析:利用欧拉函数求出1到n中与n互质的个数,n-1-phi(n)即为答案。
#include<stdio.h>
#include<math.h>
int phi(int n) //phi(n)为不超过n且与n互质的正整数个数
{
int m=(int)sqrt(n+0.5);
int ans=n;
for(int i=2;i<=m;i++)
if(n%i==0)
{
ans=ans/i*(i-1);
while(n%i==0)
n/=i;
}
if(n>1)
ans=ans/n*(n-1);
return ans;
}
int main()
{
int n;
while(scanf("%d",&n),n)
{
printf("%d\n",n-1-phi(n));
}
return 0;
}